Page 1 of 1

published web, standalone loading incomplete

PostPosted: Wed Feb 19, 2014 9:57 am
by BarMan
Hi

I have a strange thing with standalone use of a web-published course. It was builded and published as scorm package and functions allright. Now the client asked for a standalone version. We downloaded the web-version because the normal 'standalone download' doesn't even show the first page ... it looks like that's no option.

OK, the web-version.
In some occasions, the first page of a course appears but when I click on the one and only button to go to the next page, nothing happens :shock: . I then noticed some small dots which didn't disappear: 3 of 4 dots stayed on the screen. Looks like they come from the javascript function 'loadingSB' in index.html.
In other occasions the preload dots disappear (or even never appear) and the next-button works alright.
On this button is/was a scorm-action (read suspaned_data).

What I tried:
1 - remove the scorm-action on the button because in this standalone version it isn't needed.
2 - changed the security settings of the flash plugin, added the map in which the course is as trusted location.
(of course, I tried all four combinations, none, 1, 2 and 12).

It seems removeing the scorm-action ánd applying the settings on the flashplayer does the job, but I'm not sure. I put the webversion on a local webserver; in the combination 'no scorm action & flashplayer settings changed' I still have these black dots and I cannot go to the next page.

Finally the questions ;-)
- what is the meaning of the dots staying on the screen? Something like 'still not loaded completely'?
- is there a reason (and a solution) in some cases these dots appear to stay there for ever?
- can I do anything to get a stable working standalone module with a web-download?

Thanks in advance :-)

== edit
I removed all scorm actions from the module and published again for web. Seems things work, not sure though; need testing.
(*) Yes on the first page there was not only a scorm action on the button but also a lot in a pageload (defining interactions).
I think we can use an alternative js or index file which fakes a scorm interface seen from the SB module ;-)

Re: published web, standalone loading incomplete

PostPosted: Mon Feb 24, 2014 1:54 pm
by Nav
Hi,
Try to use the Offline Download option, but this time use the player.hta file, rather than the sb3player.exe, or whatever it is. People still require the exe being part of the package, but we find that the hta file is much better. Let me know if that helps!

Trying to get the web content to run offline is a pain, and requires users to change their security settings, which probably isn't a good idea.

- Nav

Re: published web, standalone loading incomplete

PostPosted: Wed Apr 15, 2015 6:27 am
by Merel
Hi Nev,

I kind of have the same problem.
When i tried to download the package with the 'web' function, or offline version, and i click on the index.html (or player) file, it opens in internet explorer. (the ING module)
But when i try to click a button nothing happens. Can i solve this in an easy way?
So i can show the module offline to other people?

Thanks in advance,


Best,

Merel

Re: published web, standalone loading incomplete

PostPosted: Mon Apr 20, 2015 10:39 am
by Nav
Hi Merel,
Did you try downloading the offline version and using the player.hta file?

- Nav

Not able to open ./cache/data_global.php