Page 1 of 1

Internet Explorer - Browser Freezes.

PostPosted: Wed Feb 13, 2013 10:45 am
by Matthias Kausch
Hi,

We are currently experiencing problems with some of our lessons in IE 8. The problem is as follows:

A small number of pages into a lesson (exported with SCORM 1.2 compliance), IE 8 freezes due to a script that takes too long to execute. The number of pages that can be accessed before the freeze varies from lesson to lesson but seems to be consistent in any one lesson (e.g. consistent freeze after page 3 in one lesson, consistent freeze after page 2 in another lesson). This does not happen in other browsers.

Is this problem known and is there a fix available that works for all Installations of IE 8?

Regards,

Matthias

Re: Internet Explorer - Browser Freezes.

PostPosted: Wed Feb 13, 2013 1:28 pm
by Nav
Hi Matthias,
Hmm, I think we need more information.

  • How do you know "IE 8 freezes due to a script that takes too long to execute"? Is there a popup message?
  • Can you send us a screengrab of the issue?
  • Also, can you tell us the name(s) of these lessons and where the issue happens (page 3, etc)? We can try to reproduce the problem here.
  • Does this also happen when viewing the published lesson in SB, or only after exporting and running on the LMS?
You can email this information at support at suddenlysmart if you don't want to post it here.

- Nav

Re: Internet Explorer - Browser Freezes.

PostPosted: Fri May 10, 2013 8:42 am
by rincewind50
Hi Nav.

I am the technical director of the business. The issue that Matthias is referring to has been explored in more detail.

All the courses run fine in Chrome and Firefox.

The problem is not specific to one course but all courses that we have produced in Smartbuilder. In IE when the course is run at certain points in the course the page sees to freeze, in fact this is just a delay in running a JavaScript. It actually consistently take 5 minutes to load the page, then the course runs fine.

This issue is only when the course is run through our LMS.

The issue would seem to be with SCOFunctions.js If I disable this file then the course runs fine in IE but obviously none of the SCORM functions work.

Have you experienced this issue before?

Re: Internet Explorer - Browser Freezes.

PostPosted: Mon May 13, 2013 11:22 am
by Nav
Hello,
We have not experienced this before. A little freezing is normal when data is sent to or from the LMS, but unless a lot of it is being transferred, it shouldn't take 5 minutes. Do you know what function is taking so long? What is being done at those certain times in the lesson? Are you transmitting lots of learner data? Or changing to a certain page, or something specific like that?

Can you try uploading the lesson and running it through SCORM Cloud (a free testing service)? You can sign up for their free account here - https://cloud.scorm.com/sc/guest/SignUpForm You can see if it happens there, and if it does, they have lots of debugging tool, including a log of all the calls that are sent (which is where I imagine the delay is coming from, though I may be wrong).

Or you can tell me exactly where I would run into this issue in a particular lesson, and I can test it on SCORM Cloud (but I think it would be better if you do it on one of the machines that you have seen the problem on before). We can also try to a do a gotomeeting and look at this issue together, but there might be issues with our time difference. I'm on Pacific Daylight Time, and could meet a little before my normal day if that would work for you.

Hope that helps! Let me know how you want to proceed.

- Nav

Not able to open ./cache/data_global.php