Page 1 of 1

Problems with FLVs - tips for Flash Video (FLV)

PostPosted: Wed Mar 25, 2009 4:49 pm
by Nav
Hi everyone,
We've had a number of issues that involve FLVs videos recently. Seems like more people are using them of late. Some of them have been SmartBuilder issues, and some of them have been problems with the FLV files themselves.

Here are some links and tools that might help you troubleshoot an issues you run into. If you've tried these out and are still having problems, please post on the forum or email us directly at support AT suddenlysmart DOT com.

Is your FLV running slowly or choppy? Concerned that the file size might be too big? Use this calculator to determine your target audience, their bandwidth, and the compression settings you should be using: http://www.adobe.com/devnet/flash/apps/ ... alculator/

Is your FLV not running at all? It could have an “invalid signature”. Please check out the FLVCheck tool.
You can find the tool here: http://www.adobe.com/products/flashmedi ... downloads/
And the documentation here: http://livedocs.adobe.com/flashmediaser ... ks_11.html
Here's a video walkthrough of how to use this tool (it's not the most user friendly interface) - http://screencast.com/t/QL5caIFaIYq5

Finally, here is a resource that talks about general FLV issues that you might run into and how to solve them: http://www.squidoo.com/flv

Hope that helps! Again let us know if none of these are helping you resolve your FLV issues.

- Nav

Re: Problems with FLVs

PostPosted: Mon Aug 17, 2009 10:06 am
by rwicker215@aol.com
Hi Nav,

Do you have any recommendations for those who develop on a Mac?

Kind regards,
Rebecca

Re: Problems with FLVs

PostPosted: Tue Aug 18, 2009 10:03 am
by Nav
Hmm... Well, that bandwidth calculator and the tips from Squidoo are still valid, but I don't have any specific advice for Mac users. Are you planning to start using FLVs, or are you using them now and running into issues?

- Nav

Re: Problems with FLVs

PostPosted: Wed Aug 19, 2009 10:42 am
by rwicker215@aol.com
Hi Nav,

We're using video in courses now, and running into inconsistent playback issues.

I'm now outputting the video to FLV via Adobe Encoder to see if that resolves the performance issues. Since the playback issues are inconsistent, it is difficult to test.

Kind regards,
Rebecca

Re: Problems with FLVs

PostPosted: Wed Sep 02, 2009 9:24 am
by Nav
On a slightly related topic, another client ran into problems when delivering a course through their LMS. The lesson would display, complete with media such as graphics, except FLV videos wouldn't show up or even load.

It seems that the LMS server was blocking the FLV file type. By changing the server settings, it was able to work. This is a quick explanation from their IT department of what they did to get it to work:
IIS -> websites -> right click on the website -> properties -> HTTP Headers -> MIME types -> New…
I added the extension: .flv
And associated it to MIME type: video/x-flv

Hope that helps someone!

- Nav

Re: Problems with FLVs - tips for Flash Video (FLV)

PostPosted: Wed Feb 01, 2012 3:50 pm
by tahiya
Just to verify, when I generate an FLV file, there isn't a list of preferred output settings that are specific to SmartBuilder? I will use the tools provided, but just wanted to make sure I wasn't overlooking a wheel someone else had already invented.
Thanks

Re: Problems with FLVs - tips for Flash Video (FLV)

PostPosted: Wed Feb 01, 2012 4:45 pm
by Nav
There are not really preferred types or settings that are unique to SmartBuilder, but it does require proper encoding. Or a "valid signature" as mentioned in the first post. If you're generating FLVs and they work, great. If not, you might want to use the tool specified to test it, or simply try using Adobe Media Encoder to convert it. The presets that it uses to create FLVs works great.

- Nav

Not able to open ./cache/data_global.php